So, You Want to 3D Print a Landscape? An Outline of Some Methods

Dylan J. McKevitt  
*Cedarville University*, dylannmkevitt@cedarville.edu

Thomas L. Rice  
*Cedarville University*, trice@cedarville.edu

Emily Jackson  
*Cedarville University*

Victoria Couser  
*Cedarville University*

Follow this and additional works at: [http://digitalcommons.cedarville.edu/alum_books](http://digitalcommons.cedarville.edu/alum_books)

Part of the [Geology Commons](http://digitalcommons.cedarville.edu/geology_commons)

**Recommended Citation**  
[http://digitalcommons.cedarville.edu/alum_books/435](http://digitalcommons.cedarville.edu/alum_books/435)
So, You Want to 3D Print a Landscape? An Outline of Some Methods

Keywords
3D printing, landscape

Disciplines
Geology
So, You Want to 3D Print a Landscape?

An Outline of Some Methods

Dylan J. McKevitt

with

Thomas L. Rice, Emily Jackson, and Victoria Couser

Cedarville University

November, 2015

Draft 4
Contents

Introduction ............................................................................................................................................. 3

Section 1: Starting With a Sequence of Overlapping Images (Photos). ................................................. 4
  Pix4D .................................................................................................................................................... 4
  VisualSFM ........................................................................................................................................... 4
  Arc 3D .................................................................................................................................................. 4
  MeshLab ............................................................................................................................................... 4

Section 2: Starting With Video. .............................................................................................................. 9

Section 3: Starting With Elevation Data in General ............................................................................... 9

Section 4: Starting with DEM or TIN Data. .......................................................................................... 9
  3DEM and AccuTrans 3D ..................................................................................................................... 9
  MicroDEM .......................................................................................................................................... 13

Section 5: Starting With a DWG File of Contour Lines. ..................................................................... 15
  SITEOPS Topo Lite ............................................................................................................................... 15
  DraftSight .......................................................................................................................................... 16
  AccuTrans 3D ................................................................................................................................... 17
  ArcGIS ................................................................................................................................................. 20
  Blender ................................................................................................................................................. 25
  Generating a solid model from a 2D surface: Method 1—Boolean ..................................................... 29
  Generating a solid model from a 2D surface: Method 2—Extruding .................................................. 32
  Generating a solid model from a 2D surface: Method 3—Extrude and Boolean ................................ 33
  Save the STL ....................................................................................................................................... 33
  MeshLab .............................................................................................................................................. 34

Section 6: Starting With LiDAR Data (or an LAS File). .................................................................... 35
  3DEM and AccuTrans3D .................................................................................................................... 35
  ArcGIS ................................................................................................................................................. 35

Section 7: Cleaning and Simplifying Point Cloud and Mesh Data. ...................................................... 39
  Cleaning Point Cloud Data ................................................................................................................ 39
  Cleaning Mesh Data .......................................................................................................................... 40
  Simplifying Point Cloud Data ........................................................................................................... 40
  Simplifying Mesh Data ...................................................................................................................... 40
So, You Want to 3D Print a Landscape? An Outline of Some Methods

Section 8: Adding Text or Symbols to Your Model ................................................................. 41
ArcGIS / ArcMap .................................................................................................................. 41
Blender ................................................................................................................................. 41
Autodesk Meshmixer ......................................................................................................... 41

Section 9: Embedding a 3D Model into a PDF ............................................................... 42
Tetra4D Converter ........................................................................................................... 42
LaTeX and U3D ................................................................................................................ 42
Matlab .............................................................................................................................. 42

Section 10: Printing Your 3D Model ........................................................................... 43
3D Printers ....................................................................................................................... 43
Materials .......................................................................................................................... 43
Printing Tips .................................................................................................................... 43

Appendix A: Some Helpful Resources ....................................................................... 44
Data ................................................................................................................................. 44
Video Tutorials ............................................................................................................... 44
Websites of Interest ....................................................................................................... 44

Appendix B: Some Common File Types Relating to 3D Printing ........................ 46
Appendix C: Programs .................................................................................................. 47
Appendix D: Calculating vertical exaggeration of your 3D model ...................... 49
Introduction
Cedarville University’s geology program initiated the use of 3D printing in the spring of 2015 with the hope of presenting a poster at the Geological Society of America Annual Meeting in Baltimore in early November. With the acquisition of two DJI Phantom drones, the program began exploring applications of drone usage, which led to the process of capturing geo-referenced images to use in 3D printing. Through much trial and error, and the gracious help of the engineering department, the geology program has printed several successful 3D models. These models include landscape models from around the country, a Dilophosaurus skull, and a Dreadnoughtus front limb.

3D printers require an STL file (a STereoLithography file) or OBJ file. However, there are numerous ways to generate these, from a variety of sources, using an even wider range of software. Many open-source programs exist that work fine; this guide will try to focus on those. However, some more-expensive (> $0) software may yield better results and accomplish what it might take a couple other free programs to. It pays to shop around, and you might discover a clearer / easier method than what’s described here.

This is only an outline; as such, it won’t go too in-depth on any of the programs, but rather show you the bare-bones procedures. Plenty of videos, web pages, and other resources are out there if you look. And, considering how this field (along with that of UAV / drone usage) is exploding, much more is sure to come!

Please check out the Appendices for some helpful resources and descriptions of file types and programs referenced in this guide.

If you have any suggestions on adding to or editing this guide, please don’t hesitate to make them! Some sections are very bare-bones, or incomplete and or unorganized, or all of the above. Our work with drones and 3D printing will continue, and I’ll update and edit this guide as we progress. If you’d like new versions as they come, or just have some questions or comments, please don’t hesitate to e-mail me at dylanmckevitt@cedarville.edu.

Oh, and our research poster detailing some of the processes outlined in this guide was presented at the GSA Annual Meeting in Baltimore on November 4th; Paper No. 289-5, Booth 61. A digital copy should be available online soon.

So, grab a cup of coffee or seltzer water mixed with fruit juice, crank some of your favorite Spotify or iTunes jams, and have some fun!

D.J. McKevitt, November 2015

Cedarville University ‘15
Section I: Starting With a Sequence of Overlapping Images (Photos).

Using UAVs, it is possible to obtain a series of overlapping images that can be processed into a DEM.

---

Pix4D

For processing in Pix4D, the captured images should be geo-referenced. If using a DJI drone, the DJI app can be used to create a pre-planned flight, allowing the user to set a specific number of way-points to which the drone will fly. Images can be taken along route via an automatic image capturing feature or manually.

Process the images (reference to Pix4D site in Appendix C). Output either a final 3D model (in OBJ format) for use in Blender (Section 5), or a point cloud file (PLY, XYZ, LAS, or LAZ format) for processing in a program like MeshLab (this section, MeshLab subsection).

---

VisualSFM

See Appendix C for info about this free program. Follow the instructions provided on the website to avoid headaches in setting up and running the program on your computer.

Once set up, it only takes four easy (but time-consuming) steps to generate a PLY pointcloud! 1) Load your photos. 2) Match the images. 3) Sparse reconstruction. 4) Dense reconstruction.

---

Arc 3D

If you have a bunch of images but lack the processing power or resources to generate a point cloud, or if you just want an “easy way out”, simply use Arc 3D’s free webservice (referenced in Appendix C) where you just upload your images, let them do all the work, and receive a textured OBJ file. True piece of cake.

---

MeshLab

In MeshLab, navigate to File→Import Mesh, and select your point cloud. Once opened, you first need to compute the normals for the points; Filters→Normals, Curvatures and Orientation→Compute normals for point set, and apply. This may take a few moments.
So, You Want to 3D Print a Landscape? An Outline of Some Methods

Wanna see a fuzzy blue Pomeranian? Render→Show Normal/Curvature.

Next, Filters→Remeshing, Simplification, and Reconstruction→Surface Reconstruction: Poisson. Options here include setting the Octree Depth and Solver Divide; select the “Help” button for a brief
description of both. I found setting the Octree Depth at 10 and Solver Divide at 8 worked pretty well. Select Apply, and once it says “Not Responding” go grab a cup of coffee, or take your un-blue (but still fuzzy) Pomeranian for a walk.

When you return, a strange shape may surround your point cloud. That’s just the result of the Poisson meshing. You can change the viewing options in the Dialog box to the right to “hide” your point cloud. Also, note the old Render→Lighting→Double side lighting trick. To Simplify the mesh for further work, make sure your mesh is selected and simply navigate to Filters→Cleaning and Repairing→Select Faces with edges longer than..., check the “Preview” box, and move the slide bar to select whatever part of the mesh you want to delete. Apply. Finally, just click on the Delete Faces and Vertices button in the upper right.
Next, you should clean the mesh. Many options lie under Filters→Cleaning and Repairing; for details, I refer you to Mister P.’s amazing YouTube Tutorials (referenced in Appendix A).

Simplifying the mesh is the logical next step; this is also helpful on large file-size meshes produced in Blender that you want to downsize without losing too much (if any) resolution. Simply choose Filters→Remeshing, Simplification and Reconstruction→Quadric Edge Collapse Decimation. This filter can be repeated multiple times. For details, I once again refer you to Mister P. Or if you’re tired of hearing his music for the moment, proceed by setting either the percentage reduction (as a decimal; usually 0.5 works good for the first iteration), or Target number of faces (compared to the current number, noted at the bottom right of the window—the value in parentheses refers to all the open point clouds / meshes, while the other refers only to the selected object). Apply, export the mesh, and be amazed at how much the file size dropped!
The mesh can be saved and exported in a variety of formats simply by choosing File ➔ Export Mesh As. Proceed to giving the model “thickness” in Blender (one of three methods in Section 5) (or, if you brought the model in from Blender for simplifying / cleaning you’re done!).
Section 2: Starting With Video.
Some software (including Pix4D) allows the extraction of a sequence of overlapping images from video, which can in turn be processed as outlined in Section 1. The author hasn’t tested this technique yet…

Section 3: Starting With Elevation Data in General.
A quick search of the internet will reveal a plethora of freely available elevation data for areas around the world, from county-size scale and larger to country-wide scale. This free data can be imported into ArcGIS and manipulated in ArcMap to generate a DEM (as a .jpg or .png image), which can then be converted into a printable, STL file using other software (e.g. Blender). ArcMap features diverse tools in ArcToolbox for converting between different data types. Or, a cheaper (and easier option) utilizes 3DEM and AccuTrans 3D – see Appendix C for general info concerning these programs and how to acquire them.

Section 4: Starting with DEM or TIN Data.
If you have a DEM or TIN, then you’re already halfway to printing a 3D model! ArcMap has tools in ArcToolbox for converting between TINs and DEMs (referred to as ‘Raster’ in ArcMap). ArcMap can also generate contour lines from TINs or DEMs… but for our projects, that’s going in the wrong direction. If you have an “image” DEM (e.g. in PNG or JPG format), as is obtained from ArcMap, then proceed to Section 5. However, if your DEM is in another format (e.g. GeoTIFF, ASCII DEM, LAS,…), as is commonly obtained from many internet sources, you can bypass ArcGIS and quickly utilize some free (or nearly so) programs to generate a 3D model—see the rest of this section.

For select locations, you can obtain DEM data from http://opentopography.org/ (see Appendix A). For this example, I selected Wizard Island in Crater Lake National Park. Data files available from this site include LAS and GeoTIFF DEMs. Here are workflows for either of these file types that consequently work with many other DEM data types… experiment with these programs for yourself!

3DEM and AccuTrans 3D
See Appendix C for info about these programs and how to obtain them.

We’ll use 3DEM to convert our LAS digital elevation model file (just one of many accepted by 3DEM) to a USGS ASCII DEM. Select File→Load Terrain Model, select your file, and open it.
A window will pop-up allowing you to change the resolution of your LiDAR DEM. I just accepted the defaults.
Although this program has many other useful applications (explore them if you have time!), for this example we’ll simply navigate to File→Save USGS ASCII DEM.

Next, open AccuTrans 3D. Select File→Open DEM As→USGS 1-degree (ASCII) (*.dem) [or whatever file type you have].

Now, select (from the top) Dem→Convert to 3D (less water), and modify the vertex interval if you’d like to reduce the number of vertices / triangles. Select OK.
Some optional steps include next selecting Tools_1→Adjust Object, and scaling-down the model, changing its position, and/or rotating it. All these can also be done in Blender later-on; they’re described in Shapespeare’s first video tutorial listed in Appendix A.
The final step: File→Save As, and select the STL file type. Now you’re ready to import the model into Blender to give it thickness! Use one of the three methods in Section 5.

MicroDEM

Another option involves using MicroDEM (Appendix C) to export an OBJ file to be opened in Blender. For this example, I used a GeoTIFF of Wizard Island. I had obtained this from http://opentopography.org/, but you can also save a GeoTIFF directly out of 3DEM.

First, go to File→Open→Open DEM, and select your TIN / GeoTIFF file. The file will load. Then just select File→Save DEM→Caveat emptor. This saves an object (OBJ) file which can be imported directly into Blender and given ‘thickness’ to generate your final 3D model (using one of the three methods outlined in Section 5).
So, You Want to 3D Print a Landscape? An Outline of Some Methods
Section 5: Starting With a DWG File of Contour Lines.

SITEOPS Topo Lite

First, obtain a DWG of contour lines! Let’s use Massies Creek Gorge area in Cedarville Ohio, with the Indian Mound to the northwest.

Navigate to the SITEOPS Topo Lite website (https://app.blueridgeanalytics.com/Topo_Lite/).

Here it’s pretty straight-forward. Much like using Google Maps, you just navigate to the location of interest. When you are zoomed-in far enough, you’ll have the option (in the upper right) to ‘Select Location’. [note the ‘map / satellite’ options also in the upper right]
Click on ‘Select Location’, enter some information, and you’ll promptly receive an e-mail with a link to the DWG file for your site.

You can open this file in DraftSight if you want to view it. In DraftSight, you could ‘trim-down’ the DWG and re-save it as another DWG. I won’t mess with that here.

**DraftSight**

See Appendix C for info about this free program for viewing DWG files. You could continue with ArcGIS to convert these contour lines into a DEM, but that’s an expensive (and, in my opinion, more complex) option. A better workflow involves opening your DWG in DraftSight. Then simply navigate to the Layers drop-down and turn off the unnecessary layers by clicking on the “green circles”. I only kept the Contour Existing Grade and Contour Existing Grade Index layers visible.
So, You Want to 3D Print a Landscape? An Outline of Some Methods

Next, simply go to File→Save As, and save it as a *.dxf file (I used the R2013 Drawing type).

**AccuTrans 3D**

Open your .dxf contour line drawing file with AccuTrans 3D by selecting File→Open As→DXF.
Next, simply choose Tools_1→Convert Contour Lines to Landscape/Terrain. I just accepted the default options in the pop-up dialog box and hit OK.

This bit of spectacular magic takes a few moments... and then, voilà!
Navigate to Dem→Convert to 3D (less water). I accepted the defaults. Hit OK!
Bam! Simply save it as an STL by choosing File → Save As (I used the ASCII option). Now, use one of the three Blender methods outlined in this section to give your model thickness.

**ArcGIS**

This option isn’t as good as the one previously described for working with a DWG of contours... but it’s the first I used, and I’ll include it for sentimental reasons.

Open a new map in ArcMap. Navigate to View → Data Frame Properties → Coordinate System. Choose whichever you want to use (I will use NAD 1983 (2011) StatePlane Ohio South FIPS 3402 (US Feet)). Then add a base map if you’d like (File → Add Data → Add Basemap). Next, bring in your DWG file by selecting Add Data, and then the DWG file. You may have to add a folder connection... Hit ‘OK’ when the ‘Unknown Spatial Reference’ dialog box pops up. The DWG should automatically ‘go to’ the correct location; to check this, in ArcMap, under Table of Contents, right-click on the ‘SITEOPS.dwg Group Layer’ and select ‘Zoom to Layer’. If there’s a base map, it should correctly overlay it. If it doesn’t... that’s no big deal (at least for this exercise).
The next step is to convert these contour lines to a DEM (digital elevation map). [You could also convert them to a TIN—a triangulated network—by selecting Arc Toolbox → 3D Analyst Tools → Data Management → TIN → Create TIN; however, what we need here is a DEM.] Select Arc Toolbox → 3D Analyst Tools → Raster Interpolation → Topo to Raster.
In the ‘Input feature data’, select the polyline file. Under the ‘Field’ heading, change ‘Color’ to ‘Elevation’ by using the drop-down menu. Leave the ‘Type’ as ‘Contour’. Then select where you want the ‘Output surface raster’ to be saved; be careful how you name the output file (sometimes just having ‘strange’ characters in the file name, such as a dash [-] or underscore [ _ ], could cause error messages—see image below). The rest of the options can be left as default.
Be patient while ArcMap generates the DEM. When finished, it will automatically load as a Layer.

Next, right-click on the DEM layer name in the Table of Contents → Properties → Symbology → Classified. Set ‘Classes’ at 32 (the max) and the ‘Color Ramp’ to black-white, so the highest elevation is white [if this is not an option, right-click on the Color Ramp → Properties, and change Color 1 to black and Color 2 to white]. Hit ‘OK’.
Next, go to View ➔ Layout View. Here is where you ‘lay out’ your map. You can right-click on the ‘page’ and select ‘Page and Print Setup’ to set the dimensions of the map that you’ll export. Then resize the Data Frame by right-clicking on the map ➔ Properties ➔ Size and Position. Set the X and Y positions to ‘0’ and the Width and Height to match the ‘page’ dimensions, so the map image will take up the entire page. Double-click on the map image to activate the Data Frame; use the Zoom In/Out, Pan, and Select Elements tools to position the DEM. Make sure the Basemap layer is invisible by unchecking the box next to its name in the Table of Contents (this will remove that ‘source’ information at the lower-right of your map).
Finally, export the DEM as an image by selecting File → Export Map. You can set the resolution (400 dpi works fine) and export it as a .jpg or .png image.

**Blender**

If you chose the ArcGIS route, or if you just have a grayscale DEM image (or, for that matter, any image you want to make 3D), read on!

That’s it for ArcGIS. The next step is to generate a 3D image (STL or OBJ) file from your .jpg or .png image. We’ll utilize Blender, but other programs also work. Essentially, we’ll be stretching the black-and-white image (with shade corresponding to elevation) so the lightest-colored parts are ‘raised’ the highest. Then we’ll give the image some ‘thickness’ before saving it as an STL.

Open a new file in Blender. For first-time users, select File → User Preferences → Add-ons. Here you’ll find a group of ‘Import-Export’ Add-ons. Make sure you check (to enable) the ‘Import Images as Planes’ and the ‘STL format’ ones (enabling all the others is okay too).
Next, delete that cube; make sure it’s selected, then under ‘Edit’ on the left select ‘Delete’. [Also helpful is to know the ‘Undo’ / ‘Redo’ buttons are under the ‘History’ section—below ‘Edit’.] Next, File → Import → Images as Planes. Select the DEM you saved from ArcMap, and import it. It will appear as a blank, grey plane.
So, You Want to 3D Print a Landscape? An Outline of Some Methods

If you want to actually view the image, select ‘Texture’ in the ‘Viewport Shading’ menu.

You can view and change the dimensions of the image (and its location) by selecting the “+” in the upper right of the window; this will open some tools.
To the right, select the ‘Add Modifiers’ tool [the wrench icon], and then add the ‘Subdivision Surface’ (under ‘Generate’) and the ‘Displace’ (under ‘Deform’) modifiers.

With the ‘Subdivision Surface’ modifier, select ‘Simple’ instead of ‘Catmull-Clark’, and change ‘View’ to 8 or 9 (later, you can play with this… the higher you go, the ‘better resolution’ you get, but it’s also more
So, You Want to 3D Print a Landscape? An Outline of Some Methods

difficult to rotate / process the image... and the resulting STL will be a larger file). With the ‘Displace’ modifier, make sure your image is selected (under ‘Texture’), the ‘Texture Coordinates’ are set to ‘UV’, and ‘Direction’ is ‘Normal’. Reduce the ‘Strength’ to something like 0.1 or 0.2 [this is essentially your vertical exaggeration; see Appendix C on how to calculate the actual vertical exaggeration of your finished model].

Hit ‘Apply’ for both modifiers. Order matters; apply the Subdivide modifier first.

Generating a solid model from a 2D surface: Method 1—Boolean
This method involves cutting the 3D model from a 3D object (cube, box, cylinder... whatever) using the 2D surface you just created as a guide. Or maybe you have a 2D STL surface from another method (like that using DraftSight and AccuTrans 3D described earlier in this section); in that case, import your STL and use either this method, Method 2, or Method 3.
Hit “7” to get an overhead view of the 2D plane, and then “5” to take off perspective (so you see square edges). Then Add $\rightarrow$ Mesh $\rightarrow$ Cube. Like you could have done with the image plane, you should now adjust the cube’s dimensions (in the X and Y directions) to match the 2D surface, or to lie slightly within the 2D surface’s edges. Either you can manually adjust the dimensions and location by expanding the toolbar (as noted previously), or select the cube and the “Scale” Transformation Manipulator near the bottom of the screen and then dragging the ends of the X/Y/Z handlebars in the viewer window. The thickness of the cube below the bottom of the 2D plane will be the thickness of your model’s base.
Finally, add a ‘Boolean’ Modifier. Make sure the cube is selected, choose ‘Intersect’ for the Operation, and then select the 2D plane for the Object. It will take a moment or two to Boolean. Apply it.
Those orange glowworms crawling all over your 3D model can now be annihilated by altering the visibility in the layout tree so only the “cube” is visible.

Generating a solid model from a 2D surface: Method 2—Extruding

This method works well if the 2D surface you generate isn’t a “nice” shape (like a rectangle), or has uneven edges, and you want to keep the entire surface (not just “trim out” an area of interest using the Boolean method).

So, for this example, we’ll use data available from OpenTopo (see Data under Appendix A). The location: Wizard Island, Crater Lake National Park. I already generated an object file using MicroDEM (see Section 4), but any OBJ or STL file can be used.

Import the Object file into Blender. Initially, it may not look just right; that’s because the object is larger than the view constraints; under View, change Clip End to a really large number. Also, the object may come in so the “up” direction is oriented along the Y-axis. To change it to the Z-axis direction, select the object, type “r” for rotate, “x” to constrain the rotation to the X-axis, and then “-90” and “Enter” to rotate it.
Now, to turn this 2D surface into a 3D object. This process is most useful on surfaces with a very uneven boundary edge; however, even though this one has nice square edges, it’ll still work to illustrate the process.

Select the object. Enter Edit Mode. Hit “1” on the number pad to get a straight-on view. With everything selected, hit “e” for extrude, “z” and “z” again to lock the extrusion along the Z-axis, and then move the cursor down however far you’d like the base to be.

The bottom now is a negative of the top surface. To flatten it, type “s”, “z”, “0”, and “Enter” to scale the base to a flat surface. If you zoom in on the bottom, it may display many little triangles; these are all of the points from the top surface that have been extruded downwards. Such a large number of points makes for an unnecessarily large file; you can sometimes reduce them by choosing “Face Select”, selecting the bottom, and then Delete ➔ Dissolve Faces.

Generating a solid model from a 2D surface: Method 3—Extrude and Boolean
Another option involves extruding the surface in blender, and then inserting a plane to be Booleaned with the extrusion; details at https://www.youtube.com/watch?v=Ag-cP-tiO1k.

Save the STL
Finally, to save it as an STL. Go to File ➔ Export ➔ Stl.

Now you can import the STL into a 3D printing program to print it! However, if you want to view the model first, MeshLab works pretty well. Just import the STL and play with the viewing options.
So, You Want to 3D Print a Landscape? An Outline of Some Methods

MeshLab
For MeshLab, navigate to File → Import Mesh. Select the STL. Initially it will appear black; to make it visible, go to Render → Lighting → Double Side Lighting.

Note; the ‘ledges’ on the model are essentially contour lines—they correspond to the different shades of the original DEM that was created in ArcMap. To see how much elevation change each ledge represents, just check what elevation interval each shade of gray corresponded to in ArcMap (if you made this model from a grayscale .png or .jpg produced in ArcMap).

The End. Of this section.
Section 6: Starting With LiDAR Data (or an LAS File).
LiDAR (LAS files) is available for many locations, for free! Once again, we’ll use the Massies Creek Gorge area in Cedarville, OH as an example in going from LAS data to a 3D model.

First, obtain LiDAR data for your site, in the form of LAS files (see Appendix A). For this example, I got it from http://ogrip.oit.ohio.gov/ServicesData/GEOhioSpatialInformationPortal/OhioSpatialDataInfrastructureDownloads.aspx.

Free LiDAR data is also available for select locations from http://opentopography.org/ (see Appendix A).

3DEM and AccuTrans3D
See Section 4 for a simple and effective workflow! (Note: these programs are free, or nearly so, easy to use, and probably a better workflow than using ArcGIS... yeah, I’m pretty sure of that. I include the following ArcGIS section out of nostalgia... if you’re an ArcMap junkie, help yourself. Otherwise, please go to Section 4. That’s S-e-c-t-i-o-n-4. Please!)

ArcGIS
Open ArcMap (I’ll be using the Massies Creek Gorge dataset used in Section 5). Select ArcToolbox → Data Management Tools → LAS Dataset → Create LAS Dataset. Browse to the appropriate folder and select the .las files. Choose the Output LAS Dataset file name and location. Leave the other options at Default (but feel free to experiment if you choose!), and hit OK. [Once again, be careful that you don’t include any ‘strange’ characters in the file name, or else it may not work!]
Next, select ArcToolbox → Conversion Tools → To Raster → LAS Dataset to Raster. Browse to your Input LAS Dataset, choose the file location and name of the Output Raster, and leave the other options at default. Hit OK.
The resulting raster dataset (DEM) should appear automatically as a layer. Next, adjust the map in Layout View (as described in Section 5), and Export the map as a JPEG or PNG (I used 600 dpi resolution).
Finally, open the image in Blender and follow the procedure outlined in Section 5 to generate a 3D model.

Voilà! End of this section.
Section 7: Cleaning and Simplifying Point Cloud and Mesh Data.

Cleaning Point Cloud Data

Once you have a point cloud (from processing with a program like Pix4D or VisualSFM), the next step may be to clean it up a bit in MeshLab (this step isn’t necessary). First, navigate to File→Import Mesh, and select your point cloud (here, I utilize a PLY of Cedar Lake, Ohio obtained from 157 UAV images processed in Pix4D).
MeshLab features many Filters for processing both point clouds and meshes, but to begin with it might be easiest to use the Select Vertex Clusters tool in conjunction with Delete Vertices.

For more info, see Mister P.’s Tutorials referenced in Appendix A.

Another cleaning option involves Blender; details at https://www.youtube.com/watch?v=wM52RaM6sTo.

Cleaning Mesh Data

MeshLab usually works well; see Mister P.’s YouTube Tutorials referenced in Appendix A.

Blender is another viable option. Not only can you select and delete faces / vertices, but you can also close holes. Check out some YouTube videos.

Simplifying Point Cloud Data

Discussed briefly in Section 1. More here in future versions of this guide...

Simplifying Mesh Data

Ditto for above. And, again, Mister P.’s amazing Tutorials.
Section 8: Adding Text or Symbols to Your Model.

Want to add text or symbols (like north arrows or scale bars) to your 3D model? Piece of cake...

**ArcGIS / ArcMap**

One option is to overlay a symbol or text onto the ArcMap map using ‘Insert’ before exporting it. Recolor them in grayscale, so wherever they lie on your map they are distinct from the colors below. If the text / image is lighter than the underlying shades of the DEM, it will stand in relief (embossed) on the finished model; if darker, it will be engraved. Of course, the sharper the contrast between the shades of the underlying landscape and the text / image, the deeper it will be “engraved” or “embossed”. Continue processing the DEM image in Blender as outlined in Section 5.

**Blender**

Blender can be used to write text, extrude it, and Boolean it to emboss or engrave onto a model. The Boolean modifier can add or subtract any two overlapping meshes; see Section 5.

**Autodesk Meshmixer**

Autodesk Meshmixer is useful for unioning or subtracting meshes from each other; import your 3D landscape along with a mesh of text or a symbol and combine them.
Section 9: Embedding a 3D Model into a PDF.

**Tetra4D Converter**

A pricey option, but you can take a free trial for a test run. Pretty straight-forward; see Appendix C.

**LaTeX and U3D**

A free option (untested by the author as of this time…) involves using LaTeX (with the media9 package – not the outdated movie15 package) to embed a U3D file-type model. Details at [http://rainnic.altervista.org/content/embed-3ds-pdf-latex-u3d](http://rainnic.altervista.org/content/embed-3ds-pdf-latex-u3d). Google will gladly help you with any questions / concerns. Or, if I ever succeed, I could (and will update this section).

**Matlab**

Apparently, Matlab can also output a U3D format model for embedding in a PDF (still using LaTeX). However, maybe there’s a way to bypass LaTeX and use only Matlab… I haven’t tried this method yet, but some Googling/research may be worthwhile for those familiar with Matlab! For a start, check out:

[https://github.com/johnyf/fig2u3d](https://github.com/johnyf/fig2u3d)

Section 10: Printing Your 3D Model
This section will outline some of the many available options in 3D printers and materials, along with some printing tips.

3D Printers

Materials

Printing Tips
If you’re using an extrusion-type printer (like the MakerBot that lays-down a string of ABS plastic), your final model will have a “contoured” appearance on the top surface if it’s printed with the top “land surface” oriented in the “up” z-direction. This layered, contoured effect can be avoided by printing the model so the “land surface” is oriented along the x- or y-direction, so the model is “sitting on its side.” Another benefit of this method is a shorter printing time; although the model will be “taller”, it’ll also be narrower so the extruder doesn’t need to move over such a laterally extensive range (i.e. less wasted movement).
Appendix A: Some Helpful Resources

**Data**

[https://app.blueridgeanalytics.com/topolite/](https://app.blueridgeanalytics.com/topolite/): Site engineering software by BLUERIDGE Analytics; a free online service that e-mails you a DWG of contour lines (1 ft interval) for any area in the U.S.A. you select.

[http://www.diva-gis.org/Data](http://www.diva-gis.org/Data): A nice variety of geospatial information, including global elevation data.

[http://gis5.oit.ohio.gov/geodatadownload/default.htm?data=osip2](http://gis5.oit.ohio.gov/geodatadownload/default.htm?data=osip2): The Ohio Geographically Referenced Information Program (OGRIP)—lots of good data (LiDAR, DEM, TIFF...).

[http://opentopography.org/](http://opentopography.org/): Free, high-resolution LiDAR data (under the ‘Find Data’ button) for select locations in the U.S. and a few other places around the world. An NSF-funded project with the San Diego Supercomputer Center. The site can also generate DEM/TIN files (like a GeoTiff TIN that can be opened in MicroDEM... see Section 4).

[https://www.thingiverse.com/](https://www.thingiverse.com/): 3D models of things. A diverse assortment. And you can post models you make on there too!

**Video Tutorials**

[https://www.youtube.com/watch?v=fe2zxcKSic](https://www.youtube.com/watch?v=fe2zxcKSic): Shows how to convert any photograph into a 3D-printable model, using Blender. We follow a similar same process to make 3D landscape models, but our landscape ‘photograph’ is a grayscale DEM. (However, we don’t use the rudimentary extrude-and-scale technique to get a good flat base; we Boolean!)

[https://www.youtube.com/watch?v=t4ICkvyJv0](https://www.youtube.com/watch?v=t4ICkvyJv0) and [https://www.youtube.com/watch?v=DlDSRU2nTXA](https://www.youtube.com/watch?v=DlDSRU2nTXA): Making 3D Prints from LiDAR Data Parts 1 & 2, by Shapespeare. Some good, thorough videos concerning data gathering and manipulation, and some other software and data sources. Also, links to a 3D-printing podcast called ‘3D Printing Today’ on ITunes and Stitcher Radio.

[https://www.youtube.com/user/MrPMeshLabTutorials](https://www.youtube.com/user/MrPMeshLabTutorials): Mister P.’s MeshLab Tutorials; everything from the basics to cleaning and simplifying meshes and projecting a colored raster image onto your model!

[https://www.youtube.com/watch?v=Kl87Gubt2Co](https://www.youtube.com/watch?v=Kl87Gubt2Co), [https://www.youtube.com/watch?v=wBKidr0e-XA](https://www.youtube.com/watch?v=wBKidr0e-XA), [https://www.youtube.com/watch?v=S7HeJvlKcs](https://www.youtube.com/watch?v=S7HeJvlKcs): Very helpful videos detailing a workflow from drone footage through Visual SFM and then viewing in MeshLab.

**Websites of Interest**

[http://muearthlab.org/2015/02/3d-printing-topographic-maps-from-dems/](http://muearthlab.org/2015/02/3d-printing-topographic-maps-from-dems/): Mansfield University of Pennsylvania; a small public university with a big UAV / 3D-printing initiative. This particular web page features a process for printing landscapes from DEM imagery, similar to what is outlined in this guide. These guys are really getting into it!

http://www.shapeways.com/: Shapeways, the company for 3D model inventors; if you don’t have access to a 3D printer, you can upload your model on their site, choose from one of over 50 materials, get a price quote and (if you like the price) have them ship the printed model to your door.

Appendix B: Some Common File Types Relating to 3D Printing

**DEM**: Standard geospatial file format developed by the United States Geological Survey for storing a raster-based digital elevation model.

**DWG**: AutoCAD and Open Design Alliance applications, Autodesk Inventor Drawing file.

**JPEG or PNG**: Digital raster image formats. Joint Photographic Experts Group format supports lossy compression; Portable Network Graphics supports lossless data compression.

**LAS**: LAser format developed for LiDAR data (Light Detection And Ranging is an optical remote-sensing technique that uses laser light to densely sample the surface of the earth, producing highly accurate x,y,z measurements).

**OBJ**: Wavefront Technologies’ format for representing 3D geometry; stores the position of each vertex, the UV position of each texture coordinate vertex, vertex normals, and the faces that make each polygon defined as a list of vertices, and texture vertices.

**PLY**: Polygon File Format / Stanford Triangle Format; stores a list of nominally flat polygons with possible properties including color and transparency, surface normals, texture coordinates and data confidence values.

**STL**: Stereo Lithographic data format used by various CAD systems and stereo lithographic printing machines; describes only surface geometry.

**TIN**: Triangulated irregular network; vector-based GIS format used to represent a surface.

**U3D**: Format used for embedding models into PDF documents.

... and there are many others!
Appendix C: Programs

3DEM Terrain Visualization—available for free from [http://freegeographytools.com/2009/3dem-website-is-gone-but-3dem-still-available-here](http://freegeographytools.com/2009/3dem-website-is-gone-but-3dem-still-available-here). A very handy, easy-to-use program for visualizing digital elevation model data as colored, shaded terrain. It accepts various DEM file types (pointclouds like LAS or XYZ, DEM, GeoTIFF, ...), and can output GeoTIFF and ASCII DEMs (among others!). You can also easily create animations (rotations, flybys) and overlay maps (e.g. topo maps) onto the DEM terrain.

AccuTrans 3D—from MicroMouse Productions. A very handy program for conversion of 3D geometry between many file formats, among other features. Available for the very low price of $20 (Canadian), or a fully-functional 30-day trial for free. Find it at [http://www.micromouse.ca/index.html](http://www.micromouse.ca/index.html).

Arc 3D—free at [http://homes.esat.kuleuven.be/~visit3d/webservice/v2/](http://homes.esat.kuleuven.be/~visit3d/webservice/v2/). This useful web service allows you to upload your images, and then their tools do all the work to perform 3D reconstruction yielding a textured OBJ file, and shoot you an e-mail when finished.

ArcGIS / ArcMap—this is a little pricy, but you can get a free 60-day trial version from their website. And once that trial is over, you can get another by just signing-up again with a different e-mail address. Free trial here: [http://www.esri.com/software/arcgis/arcgis-for-desktop/free-trial](http://www.esri.com/software/arcgis/arcgis-for-desktop/free-trial). Or, you can buy it;

Autodesk Meshmixer—free from [http://www.123dapp.com/meshmixer](http://www.123dapp.com/meshmixer). If you already have 3D model(s), this program lets you combine them, create overlay patterns, and mold / refine surfaces. Not necessary for 3D printing; however, you can subtract or add some 3D text models to your landscape model (if you don’t use the process noted above in ArcMap).

Blender—free from [https://www.blender.org/download/](https://www.blender.org/download/). It can do a LOT, far beyond what we use here for 3D printing.

DraftSight—by Dassault Systemes, the makers of SolidWorks; free download at [http://www.3ds.com/products-services/draftsight-cad-software/free-download/](http://www.3ds.com/products-services/draftsight-cad-software/free-download/)

LaTeX—a high quality type-setting system, free from [https://latex-project.org/](https://latex-project.org/). See Section 9 for how it can be used to embed 3D models into PDFs!


Pix4D—free trial version of Pix4Dmapper Discovery from [https://pix4d.com/download/](https://pix4d.com/download/). This version has limited processing and output capabilities. A trial version of the Pro version is also available...
So, You Want to 3D Print a Landscape? An Outline of Some Methods

after downloading Discovery. Otherwise, the Pro version costs $350/month, $3500/yr, or $8700/life. Requires quality RAM and graphics card for image processing.


**VisualSFM**—free from [http://ccwu.me/vsfm/](http://ccwu.me/vsfm/) by Changchang Wu. Load a sequence of overlapping images and generate a PLY surface via 3D reconstruction! Like Pix4D, the image processing requires a lot of computer RAM and a good graphics card (my HP Envy15 laptop, with an Intel Core i7 processor, 8 GB RAM, and the standard Intel HD Graphics got bogged-down processing 51 landscape images...). Used in conjunction with Yasutaka Furukawa's CMVS software. Follow the installation guide appropriate for your system.
Appendix D: Calculating vertical exaggeration of your 3D model.

Some of the workflows I outlined produce models with no vertical exaggeration; others (such as manipulating a PNG or JPG image in Blender), may produce a model with unknown vertical exaggeration. In that case, the following method may be helpful.

Once your 3D model is printed, measure the difference between the lowest point and the highest point of elevation (Y'). Also measure the length along one side (X'). Next, utilizing a resource like Google Earth or ArcMap, calculate the total actual elevation change of your site (Y) [measured from the same points you used on your model to calculate Y'}. Also measure the ground distance along one side of your site (X) [the same side you measured on your model].

Now, use the equation* below to solve for the vertical exaggeration (n).

\[
\frac{Y'}{X'} = n \frac{Y}{X}
\]

*Units of measurements (SI or English or whatever) don’t matter, as long as the same units are used in measuring the model, and the same units are used in measuring the actual elevation change and ground length of the site. The units of Y' and X' must be the same, and the units of Y and X must be identical.